既知の互換性のないCordovaプラグイン

人気のあるCordovaプラグインをいくつかテストしましたが、CapacitorがすべてのCordovaプラグインをサポートしていない可能性もあります。Capacitorと一緒に動作しないものもあれば、競合する代替手段を提供するものもあります。プラグインが競合しているか、ビルドに問題があることがわかっている場合は、npx cap updateの実行時にスキップされます。

既存のCordovaプラグインに問題がある場合は、その問題の詳細とプラグイン情報をお知らせください

既知の互換性のないCordovaプラグイン (Subject to change)

  • cordova-plugin-add-swift-support (not needed, Capacitor has built in Swift support)
  • cordova-plugin-admobpro (see details)
  • cordova-plugin-braintree (see details)
  • cordova-plugin-compat (not needed)
  • cordova-plugin-console (not needed, Capacitor has its own)
  • cordova-plugin-crosswalk-webview (Capacitor doesn't allow to change the webview)
  • cordova-plugin-fcm (see details)
  • cordova-plugin-firebase (see details)
  • cordova-plugin-ionic-keyboard (not needed, Capacitor has it's own)
  • cordova-plugin-ionic-webview (not needed, Capacitor uses WKWebView)
  • cordova-plugin-music-controls (causes build failures, skipped)
  • cordova-plugin-qrscanner (see details)
  • cordova-plugin-splashscreen (not needed, Capacitor has its own)
  • cordova-plugin-statusbar (not needed, Capacitor has its own)
  • cordova-plugin-wkwebview-engine (not needed, Capacitor uses WKWebView)
  • cordova-plugin-googlemaps (causes build failures on iOS, skipped for iOS only)

Contributors

BackNext